Anniversary party HDU - 1520 (树形DP)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

好久没有写博客了,因为决定打ACM了,最近训练量有点大,挤不出时间,今天就是想学习新东西,以前没有接触过树形dp,只是听说,一直觉得是高大上的那种,所以今天打算接触这类题,但是实际上自己做下了,其实还好,之前做的dp题都是在线性结构上,其实也就是数组,只不过这个是放在非线性结构,规定了哪些点只能和哪些点进行状态转移。
然后今天这道题就是一道树规题,最简单的那种….
我们规定状态 dp[i][0]dp[i][1] d p [ i ] [ 0 ] 和 d p [ i ] [ 1 ]
因为每个人都有两个状态,参加和不参加,0为不参加,1为参加,
dp[i][0]就是在当前点不参加的情况下最大值。
所以最终答案是 dp[root][0]dp[root][1] d p [ r o o t ] [ 0 ] 和 d p [ r o o t ] [ 1 ] 中的最大值

状态转移方程:

dp[i][0]=json(i)max(dp[j][1],dp[j][0]) d p [ i ] [ 0 ] = ∑ j ∈ s o n ( i ) m a x ( d p [ j ] [ 1 ] , d p [ j ] [ 0 ] )

dp[i][1]=json(i)dp[j][0] d p [ i ] [ 1 ] = ∑ j ∈ s o n ( i ) d p [ j ] [ 0 ]

然后只要通过dfs去遍历即可。
现在开始写C++代码啦,java有机会补充上
代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<set>
#include<vector>
#include<queue>
#define mod 1000000007
#define pi 3.14159265358979323846
using namespace std;
int a[6005];
bool v[6005];
int dp[6005][2];
vector<int> T[6005];
int t;
void find(int root)
{
    for(int i=0;i<T[root].size();i++)
        find(T[root][i]);

    dp[root][1]=a[root];
    dp[root][0]=0;
    for(int i=0;i<T[root].size();i++)
    {

        dp[root][1]+=dp[T[root][i]][0];
        t=max(dp[T[root][i]][1],dp[T[root][i]][0]);
        dp[root][0]+=t;
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {   
    memset(v,false,sizeof(v));
    for(int i=1;i<=n;i++)
        scanf("%d",a+i);
    int x,y;
    for(;;)
    {
        scanf("%d%d",&x,&y);
        if(x==0&&y==0)
        break;
        v[x]=true;
        T[y].push_back(x);
    }
    int root;
    for(int i=1;i<=n;i++)
    {
        if(!v[i])
        {
            root=i;
            break;
        }
    }
    find(root);
    printf("%d\n",dp[root][0]>dp[root][1]?dp[root][0]:dp[root][1]);
}
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值