Ignatius's puzzle HDU - 1098 (中国剩余+扩欧)

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
11
100
9999
Sample Output
22
no
43

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 200005
#define mod 1000000007
using namespace std;
void gcd(int a, int b, int& d, int& x, int& y)
{
    if(!b){ d = a; x = 1; y = 0; }
    else
    {
        gcd(b, a%b, d, y, x);
        y -= x*(a/b);
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        if(n%5==0||n%13==0)
            printf("no\n");
        else
        {
            int d,x,y;
            gcd(n,65,d,x,y);
            //cout<<x<<endl;
            x*=47;
            while(x<0)
                x+=65;
            x%=65;
            printf("%d\n",x);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值