Candy HDU - 4465 (数学)(概率期望)

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10 -4 would be accepted.
Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000
Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000

这题在黑书上是有的,但是我给忘了,这个专题开辟的太晚了,只能希望在比赛的时候不要遇到,但是今天就认真的记录一下吧
那么我们看有多少种情况,假设当停止摸糖时,剩下 i 颗糖
那么,一共操作了n+ni
假设这i颗糖在第二个盒子里
则剩下i颗的概率是:

Cn2nipn+1(1p)ni

同理在第一个盒子里剩下:
Cn2ni(1p)n+1pni

因为精度问题,得取个对数(学到了):
p(i)=elnCn2ni+(n+1)lnp+(ni)ln(1p)+elnCn2ni+(n+1)ln(1p)+(ni)lnp

然后
ans=i=1np(i)i

 #include<iostream>
 #include<cstdio>
 #include<cmath>
 #include<cstring>
 using namespace std;
 const int maxn=400040;
 double fac[maxn],p,q; 
 int n;
 double cal(int n,int m)
 {
     return fac[n]-fac[m]-fac[n-m];
 }
 int main()
 {
     int cas=0;
     memset(nlog,0,sizeof(nlog));
     for(int i=1;i<maxn;i++)
        fac[i]=fac[i-1] + log(i);
     while(scanf("%d%lf",&n,&p)!=EOF)
     {
         q=log(1-p); 
         p=log(p);
         double ans=0;
         for(int i=1;i<=n;i++)
         {
             double v1=cal(2*n-i,n)+(n+1)*p+(n-i)*q;
             double v2=cal(2*n-i,n)+(n+1)*q+(n-i)*p;
             ans+=i*(exp(v1)+exp(v2));
         }
         printf("Case %d: %.6lf\n",++cas,ans);
     }
     return 0;
 }
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值