Candy

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2912    Accepted Submission(s): 1316
Special Judge

Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6216 6215 6214 6213 6212 



很巧妙的一道概率题 ,注意题意,最后一次选得的箱子一定是空的

根据题意,我们推出公式:

      

为什么q和p的幂是n+1,是因为题意说最后一次是空的,所以那个盒子被打开n+1次

公    式
C(m,n)=n!/((n-m)!*m!)(m≤n)
性质1
C(m,n)= C(n-m,n)
性质2
C(m,n)=C(m-1,n-1)+C(m-1,n)






数据很大,组合数就不好解决,会造成精度缺失,最后看题解发现一个巧妙的方法
log函数: log(m*n)=log(m)+log(n),  log(m/n)=log(m)-log(n),运用这个性质和组合数公式,对组合数进行打表

代码如下:

代码中f[i]表示log(i的阶乘)
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

typedef long long ll;
const int N=400005;
const int mod=1e9+5;
double f[N];
double logc(int m,int n)  //快速排列组合函数C(n,m)=exp(lggc(n,m));
{
    return f[m]-(f[n]+f[m-n]);
}
int main()
{
    double p,q;
    f[0]=0;
    for(int i=1;i<N;i++)
    {
        f[i]=f[i-1]+log(i*1.0);
    }
    int n,count=1;
    while(~scanf("%d%lf",&n,&p))
    {
        q=1.0-p;
        double ans=0.0; 
        for(int k=1;k<=n;k++)
        {
            ans+=k*(exp(logc(2*n-k,n-k)+(n+1)*log(p)+(n-k)*log(q))+exp(logc(2*n-k,n-k)+(n+1)*log(q)+(n-k)*log(p)));
        }
        printf("Case %d: %.6lf\n",count++,ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值