hdu 4465 概率+数学处理

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box. 
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
Input
There are several test cases. 
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10  5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal). 
Input is terminated by EOF.
Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer. 
Any answer with an absolute error less than or equal to 10  -4 would be accepted.
Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000
Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000
 
 
题意:给你两个盒子,盒子里边分别装着n颗糖,每天我都需要打开一个盒子吃一颗糖,设我打开盒子a的概率为p,打开盒子b的概率为(1-p),问最后当我打开其中一个盒子里边已经没有糖时,剩余盒子里糖的个数的数学期望
 
 
思路:这个题自身的思路是非常简单的,公式特别容易推,我们只用枚举一下剩余糖数的个数就可以了,当剩余糖数为i,那么这种情况对应的概率是si=c(2*n-i,n)*p^n*(1-p)^(n-i)*p+c(2*n-i,n)*(1-p)^n*p^(n-i)*(1-p),然后再求i*si的和就可以了
 
 
但是这样的话,问题就来了p^n是一个很小的数,但是double的精度有限,只会把p^n保留为0,这个还真是头疼,后来看了题解又学到了新姿势,先取log,最后结果再转化为以e为底的指数。
ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int maxn=200005;
double da[2*maxn+1];
void init()
{
    da[0]=0;
    for(int i=1;i<=maxn*2;i++)
    da[i]=da[i-1]+log(1.0*i);
}
int main()
{
    int n;
    double p;
    init();
    int q=0;
    while(cin>>n>>p)
    {
        double sum=0;
        for(int i=0;i<=n;i++)
        {
            double s1=(da[2*n-i]-da[n]-da[n-i])+(n+1)*log(p)+(n-i)*log(1-p);
            double s2=(da[2*n-i]-da[n]-da[n-i])+(n+1)*log(1-p)+(n-i)*log(p);
            sum+=i*(exp(s1)+exp(s2));
        }
        printf("Case %d: %.4lf\n",++q,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值