POJ 3468 A Simple Problem with Integers 树状数组解法

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

#include <stdio.h>
#include <string.h>

__int64 c1[100000+10];
__int64 c2[100000+10];
__int64 a[100000+10];
int n,q;

int lowbit(int k)  
{  
    return (k&(-k));  
}


__int64 sum(__int64 *c,int x)  		//求和
{  
    __int64 ret = 0;  
    while(x>0)  
    {  
        ret+=c[x];  
        x-=lowbit(x);  
    }  
    return ret;  
}  

void add(__int64 *c,int x,__int64 d)  		//修改节点的值
{  
    while(x<=n)  
    {  
        c[x]+=d;  
        x+=lowbit(x);  
    }  
}

int main()
{
	scanf("%d%d",&n,&q);
	memset(c1,0,sizeof(c1));
	memset(c2,0,sizeof(c2));
	int i,j;
	a[0]=0;
	for(i=1;i<=n;i++)
	{
		int rec;
		scanf("%d",&rec);
		a[i]=a[i-1]+rec;
	}
	for(i=1;i<=q;i++)
	{
		char qc[5];
		scanf("%s",qc);
		if(qc[0]=='Q')
		{
			int a1,b1;
			scanf("%d%d",&a1,&b1);
			__int64 ans;
			ans=a[b1]-a[a1-1];
			ans+=b1*sum(c1,b1)-sum(c2,b1);			//加上到b1处所能增加的所有的和
			ans-=(a1-1)*sum(c1,a1-1)-sum(c2,a1-1);			//减去到a1-1处所能增加的所有的和
			printf("%I64d\n",ans);
		}
		if(qc[0]=='C')
		{
			int a1,b1,d;
			scanf("%d%d%d",&a1,&b1,&d);
			add(c1,a1,d);
			add(c1,b1+1,-d);
			add(c2,a1,d*(a1-1));					//这边相当于保留(i-1)*d,就是所要减去的那部分。
			add(c2,b1+1,-d*b1);						//当超过其范围时,c2中保存的就应该是负的这一段的和,这样减去其时,就可以直接把这一段加上去了
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值