1007 Maximum Subsequence Sum

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


题型分类:动态规划

题目大意:输出给定序列的最大子列和,并输出最大子列和的首、尾元素。若给定序列全为负数,那么最大子列和定义为0,同时输出全部序列的首、尾元素。

解题思路:dp数组存储的是以当前下标为最后一位元素的最大子列和(这里看不懂的同学多读几遍,好好琢磨琢磨),若上一个dp[i - 1]为负数,那么此时以当前下标为最后一位的最大子列和一定就是单个元素,因为加上前面的元素肯定比单个元素要小(前面你的最大子列和dp[i - 1]已经为负数了)。pre数组存放的是以当前下标为最后一位元素的最大子列和的开始位置,用来确定子列和的段。


#include <cstdio>

const int maxn = 10010;

int dp[maxn], pre[maxn], seq[maxn];

int main(int argc, char** argv) {
	int K;
	scanf("%d", &K);
	bool flag = false;
	for(int i = 0; i < K; i++){
		scanf("%d", &seq[i]);
		if(seq[i] >= 0) flag = true; //判断是否全为负数 
	}
	if(flag == false){ //全为负数输出0
		printf("0 %d %d", seq[0], seq[K - 1]); 
		return 0;
	}
	dp[0] = seq[0];
	pre[0] = 0; //pre数组用来存储当前子列和的开始位置,也就是i的位置 
	int indexI = 0, indexJ = 0, maxSum = dp[0];
	for(int i = 1; i < K; i++){
		if(dp[i - 1] >= 0){ //dp存储的是以当前下标为最后一位的最长子列和 
			dp[i] = dp[i - 1] + seq[i];
			pre[i] = pre[i - 1]; //更新子列和时,开始位置不变 
		}
		else{ //若dp[i - 1]小于等于0的话,那么此时的子列和就为seq[i] 
			dp[i] = seq[i];
			pre[i] = i; 
		}
		if(dp[i] > maxSum){
			maxSum = dp[i];
			indexI = pre[i];
			indexJ = i;
		}
	}
	printf("%d %d %d", maxSum, seq[indexI], seq[indexJ]);
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值