1012 The Best Rank

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M(≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A


题型分类:排序、map

题目大意:对给定成绩的学生进行排序,对给定查询的学生序号,查询其最好的排名和对应的科目。

解题思路:使用sort函数进行排序,值得注意的是,这里题目中给定的学生编号是a string of 6 digits,虽然题目中的输入都是数字,但是我感觉是不严谨的,最好使用字符串,但这也增大了代码量。下面两种解法都给出,使用string的解法个人感觉较为严谨,虽然使用数组的解法代码更短也能通过。


解法一(使用map来输出):

#include <iostream>
#include <cstring>
#include <algorithm>
#include <map>
#include <string>

using namespace std;

const int maxn = 2010;
const int INF = 0x3f3f3f3f;
char subject[4] = {'A', 'C', 'M', 'E'};

typedef struct student{
	string id;
	int grade[4]; //grade依次存放A、C、M、E的成绩 
	int rank;
	student(){
		memset(grade, 0, sizeof(grade));
	}
}student;

typedef struct result{
	int rank;
	int sub; 
	result(){
		rank = INF;
		sub = -1;
	}
}result;

student stu[maxn];
map<string, result> mp; //存储最好的排名和对应的科目 
int order; //表示用哪个成绩进行排序 

bool cmp(student stu1, student stu2);

int main(int argc, char** argv) {
	int N, M;
	scanf("%d %d", &N, &M);
	for(int i = 0; i < N; i++){
		cin >> stu[i].id;
		for(int j = 1; j <= 3; j++){
			cin >> stu[i].grade[j];
			stu[i].grade[0] += stu[i].grade[j]; //平均数直接使用和来保存,避免了小数点的麻烦 
		}
	}
	for(order = 0; order < 4; order++){ //order表示分别是用哪个成绩进行排序 
		sort(stu, stu + N, cmp);
		for(int i = 0; i < N; i++){
			if(i == 0 || stu[i].grade[order] != stu[i - 1].grade[order]){
				stu[i].rank = i + 1;
			}else{
				stu[i].rank = stu[i - 1].rank;
			}
			if(stu[i].rank < mp[stu[i].id].rank){
				mp[stu[i].id].rank = stu[i].rank;
				mp[stu[i].id].sub = order;
			}
		}
	}
	for(int i = 0; i < M; i++){
		string query;
		cin >> query;
		if(mp[query].sub == -1){ //sub在构造函数里初值是-1,此时表示数据没有录入,即N/A 
			cout << "N/A" << endl;
		}else{
			cout << mp[query].rank << " " << subject[mp[query].sub] << endl;
		}
	}
	return 0;
}

bool cmp(student stu1, student stu2){
	return stu1.grade[order] > stu2.grade[order];
}

解法二(使用数组来输出,即假定学生的编号只有数字没有字符):

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int maxn = 2010;
const int INF = 0x3f3f3f3f;

char C[4] = {'A', 'C', 'M', 'E'};

typedef struct student {
	int id;
	int grade[4];
	student() {
		memset(grade, 0, sizeof(grade));
	}
} student;

student stu[maxn];
int Rank[1000010][4];
int order;

bool cmp(student a, student b);

int main(int argc, char** argv) {
	int N, M;
	scanf("%d %d", &N, &M);
	for(int i = 0; i < N; i++) {
		scanf("%d", &stu[i].id);
		for(int j = 1; j <= 3; j++) {
			scanf("%d", &stu[i].grade[j]);
			stu[i].grade[0] += stu[i].grade[j];
		}
	}
	for(order = 0; order < 4; order++) {
		sort(stu, stu + N, cmp);
		for(int i = 0; i < N; i++) {
			if(i == 0 || stu[i].grade[order] != stu[i - 1].grade[order]) {
				Rank[stu[i].id][order] = i + 1;
			} else {
				Rank[stu[i].id][order] = Rank[stu[i - 1].id][order];
			}
		}
	}
	for(int i = 0; i < M; i++) {
		int query;
		scanf("%d", &query);
		int bestRank = INF, bestCourse = -1;
		for(order = 0; order < 4; order++) {
			if(Rank[query][order] < bestRank) {
				bestRank = Rank[query][order];
				bestCourse = order;
			}
		}
		if(bestRank == 0)  printf("N/A\n");
		else  printf("%d %c\n", bestRank, C[bestCourse]);
	}

	return 0;
}

bool cmp(student a, student b) {
	return a.grade[order] > b.grade[order];
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值