1020 Tree Traversals

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2


题型分类:树的遍历、建树

题目大意:给出后序遍历和中序遍历,要求输出层序遍历的序列。

解题思路:由后序遍历和中序遍历建树,然后使用stl模板下的queue进行层序遍历即可。


#include <cstdio>
#include <queue>

using namespace std;

const int maxn = 35;

typedef struct Node{
	int data;
	Node *left, *right;
}Node;

int post[maxn], in[maxn], level[maxn];

Node* createTree(int postL, int postR, int inL, int inR);
void levelOrder(Node *root);

int main(int argc, char** argv) {
	int N;
	scanf("%d", &N);
	for(int i = 0; i < N; i++){
		scanf("%d", &post[i]);
	}
	for(int i = 0; i < N; i++){
		scanf("%d", &in[i]);
	}
	Node* root = createTree(0, N - 1, 0, N - 1);
	levelOrder(root);
	for(int i = 0; i < N; i++){
		if(i != 0) printf(" ");
		printf("%d", level[i]);
	}
	return 0;
}

Node* createTree(int postL, int postR, int inL, int inR){
	if(postL > postR){
		return NULL;
	}
	Node *root = new Node;
	root->data = post[postR];
	int k;
	for(k = inL; k <= inR; k++){
		if(in[k] == root->data){
			break;
		}
	}
	int leftNum = k - inL;
	root->left = createTree(postL, postL + leftNum - 1, inL, inL + leftNum - 1);
	root->right = createTree(postL + leftNum, postR - 1, inL + leftNum + 1, inR);
	return root;
}

void levelOrder(Node *root){
	queue<Node*> q;
	q.push(root);
	int num = 0;
	while(!q.empty()){
		Node* now = q.front();
		q.pop();
		level[num++] = now->data;
		if(now->left){
			q.push(now->left);
		}
		if(now->right){
			q.push(now->right);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值