POJ 2586 Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10909 Accepted: 5481

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
 
题目大意:一家公司一年中的每个月要么盈利,要么亏损,且盈利和亏损金额都固定不变,每五个月统计一次盈亏状况发现都是亏损,求一年中最大盈利总额,如果不能满足,输出”Deficit“。
 
解题思路:8次统计中会有一些月份叠加,把亏损月份集中在重叠月份最多的部分。五个月中盈利月份数i可为1,2,3,4,可计算得出i为1时有3个月盈利,i为2时有6个月盈利,i为3时有8个月盈利,i为4时有10个月盈利。
 
代码如下:
#include <cstdio>
int main()
{
    int i,a,b,sum,p;
    while(scanf("%d%d",&a,&b)!=EOF)
	{
		p=0;
		for(i=1;i<5;i++)
		{
			if(i==5)p=1;
			if(i*a>(5-i)*b)//找出五个月中盈利月份数
				break;
		}
		i-=1;
		if(i<1||p)
		{
			printf("Deficit\n");
			continue;
		}
		if(i==1)
			sum=3*a-9*b;
		else if(i==2)
			sum=6*a-6*b;
		else if(i==3)
			sum=8*a-4*b;
		else
			sum=10*a-2*b;
		if(sum<=0)
		{
			printf("Deficit\n");
			continue;
		}
		printf("%d\n", sum);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值