poj 3624 Charm Bracelet

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25370 Accepted: 11418

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


题目链接:http://poj.org/problem?id=3624


题目大意:有n只魔力手镯,已知每只手镯的重量和魔力值,求总重量不超过m的所有手镯的最大魔力总值。


解题思路:经典背包问题的简单题。dp[ v ]表示总重量在 v 以内的所有手镯的最大魔力总值。

方程为:  dp[ v ] = dp [ v -w[ i ] ] + d [ i ]  写的时候用了结构,但用两个数组记录重量和价值就可以了。


代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[12890];//dp[i]表示在重量不超过i的情况下的最大价值
struct A
{
    int w,d;//重量和价值
}a[3410];
int main()
{
    int i,j,n,m,ans=0;
	memset(dp,0,sizeof(dp));
    scanf("%d%d",&n,&m);
    for(i=0;i<n;i++)
        scanf("%d%d",&a[i].w,&a[i].d);
	for(i=0;i<n;i++)      //i从前往后,重量从大到小根据a[i]更新重量j以内的最大价值量
		for(j=m;j>=a[i].w;j--)      // 第一次遍历,重量不小于a[0].w的dp值全更新为a[0].d的值,依次遍历不断更新。
			if(dp[j]<dp[j-a[i].w]+a[i].d)     
				dp[j]=dp[j-a[i].w]+a[i].d;
	printf("%d\n",dp[m]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值