POJ 1426 Find The Multiple (dfs)

                                                       Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22773 Accepted: 9387 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题目链接:http://poj.org/problem?id=1426

题目大意:给一个数字n,求出它的每位只由0和1组成的倍数。

解题思路:因为n的大小不超过200,所以满足条件的倍数在long long 范围内,直接深搜。

代码如下:


#include <cstdio>
#include <cstring>
#define ll long long 
ll n;
bool p;
int m;
void dfs(ll x,int cnt)
{
    if(x%n==0)   //找到答案,返回
    {
        p=true;
        printf("%I64d\n",x);
        return ;
    }
    if(cnt>=18)         //在long long 的范围内,超过这个范围直接返回 
        return ;
    for(int i=0;i<=1;i++)   //枚举下一位数字是0或者1
    {
        dfs(x*10+i,cnt+1);
        if(p)
            return ;
    }
}
int main(void)
{
    while(scanf("%I64d",&n)!=EOF&&n)
    {
        m=0,p=false;
        dfs(1,0);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值