H - Post Office POJ - 1160

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.
Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
Sample Input
10 5
1 2 3 6 7 9 11 22 44 50
Sample Output
9

    题意:给你n个村庄在数轴上的坐标,要你建在其中建v个邮局,令每个村庄到他最近的邮局的距离的和最小。

sum[i][j]表示在第i和第j个村庄间建一个邮局的最短距离,我们发现把邮局建在i与j的中间也就是中位点最优,通过列举简单的例子发现规律sum[i][j]=sum[i][j-1]+x[j]-x[(i+j)/2];其中

x[i]表示第i个村庄在数轴上的坐标。最后由sum得到dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);dp[i][j]表示在前i个村庄建立j个邮局的最优解

#include<stdio.h>
#include<string.h>
int min(int a,int b)
{
    if(a<b)return a;
    else return b;
}
int main()
{
    int V,P,i,j,k,l,x[305],dp[305][305],sum[305][305];
    while(scanf("%d%d",&V,&P)!=EOF)
    {
        memset(sum,0,sizeof(sum));
        for(i=0;i<305;i++)
            for(j=0;j<305;j++)
                dp[i][j]=10000000;
        for(i=1;i<=V;i++)
        {
            scanf("%d",&x[i]);
            sum[i][i]=0;
        }
        for(i=1;i<=V;i++)
            for(j=i+1;j<=V;j++)
            {
                sum[i][j]=sum[i][j-1]+x[j]-x[(i+j)/2];
            }
        for(i=1;i<=V;i++)
            dp[i][1]=sum[1][i];

        for(j=1;j<=P;j++)
        {
        for(i=j+1;i<=V;i++)
        {
            for(k=1;k<=i;k++)
                        {
                dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
            }
        }
        }
        printf("%d\n",dp[V][P]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值