E - Monkey and Banana HDU - 1069

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

 

Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

 

题意:给出n中方块,每个方块有长宽高三个元素;每种方块有无数个;现在叠箱子,上面的箱子的长宽比下面的小;问能叠出的最大的高度;

分析:数据中的x,y,z,分别能为长宽高,也就是说每个数据对应六个箱子;

之前以为给你三个数据只能有三个不同的长方体。但

我们在排序时都是将长与长,宽与宽交,亦就是将三个数填入三个格子,自然有六种

将箱子按长宽排序;再求最大子序列的和;dp[i]表示第i个箱子为放值最上面时的最大高度

 

 

 

 

 

 

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct block{
int x,y,z;};

int cmp(block a,block b){
    if(a.x!=b.x)return a.x<b.x;
    return a.y<=b.y;
}
int main(){
    int iCase=0,n,dp[200];
    block blo[200];
    while(~scanf("%d",&n)&&n){
        int num=0,maxValue=0;iCase++;
        for(int i=0;i<n;i++){
            int xx[3];scanf("%d%d%d",&xx[0],&xx[1],&xx[2]);
            blo[num].x=xx[0];
                blo[num].y=xx[1];
                blo[num].z=xx[2];
                num++;
                blo[num].x=xx[1];
                blo[num].y=xx[2];
                blo[num].z=xx[0];
                num++;
                blo[num].x=xx[0];
                blo[num].y=xx[2];
                blo[num].z=xx[1];
                num++;
                blo[num].x=xx[1];
                blo[num].y=xx[0];
                blo[num].z=xx[2];
                num++;
                blo[num].x=xx[2];
                blo[num].y=xx[0];
                blo[num].z=xx[1];
                num++;
                blo[num].x=xx[2];
                blo[num].y=xx[1];
                blo[num].z=xx[0];
                num++;
        }
        memset(dp,0,sizeof(dp));
             sort(blo,blo+num,cmp);
             dp[0]=blo[0].z;
             for(int i=1;i<num;i++){
                int con=0;
                for(int j=i-1;j>=0;j--){
                    if(blo[i].x>blo[j].x&&blo[i].y>blo[j].y&&dp[j]>con){
                        con=dp[j];
                    }
                }
                dp[i]=blo[i].z+con;
                if(dp[i]>maxValue){
                    maxValue=dp[i];
                }
             }
             printf("Case %d: maximum height = %d\n",iCase,maxValue);
    }



}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值