P - Pascal's Travels HDU - 1208

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 


Figure 1


Figure 2
InputThe input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them. 
OutputThe output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 
Sample Input
4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1
Sample Output
3
0

7

分析:设到达点(i,j)只有从该点的上or左两个方向过来,而对于点(i,j)而言,从他的左和上两个方向来的并经过该点的路径可能不止一条,所以需要遍历每个点,让该点给其他点提供路径。设dp【i】【j】表示从出发点到点(i,j)的路径数;

#include <iostream>
#include <cstdio>
#include <cstring>
short a[35][35];

__int64 dp[35][35];int n;
using namespace std;
int main()
{

    while(~scanf("%d",&n)){
        if(n==-1)break;
        char s[200];

        for(int i=1;i<=n;i++){
            scanf("%s",s);
            for(int j=1;j<=n;j++){
                a[i][j]=s[j-1]-'0';
            }
        }
        memset(dp,0,sizeof(dp));
        dp[1][1]=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(a[i][j]==0||dp[i][j]==0){
                    continue;
                }
                if(i+a[i][j]<=n){
                    dp[i+a[i][j]][j]+=dp[i][j];
                }
                 if(j+a[i][j]<=n){
                    dp[i][j+a[i][j]]+=dp[i][j];
                }
            }
        }
        cout<<dp[n][n]<<"\n";
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值