A - Red and Black POJ 1979

A - Red and Black

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
@…# 此处数据请看原题
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0
Sample Output
45
59
6
13


  1. 题意:给定字符表,问有多少个点与@字符相连通。
  2. 思路:从起始点开始,进行搜索,搜索分四个方向,如果搜到的满足条件,记录值加一,并以此点为根节点继续向四个方向搜索;搜索到不满足的点直接返回。
  3. 失误:用广搜的思路没有错,条件主干代码也没有错,主要是一些小的问题检查耗费了时间:数组越界,变量用反了,字符输入了。形式上的错误·还好找,逻辑上的错误就不好找到了。
  4. 代码如下:
#include<cstdio>
#include<cstring>

const  int INF=0xfffffff,MAXN=1e2+10;
char  a[MAXN][MAXN];//MAXN不能超过10^4,再大就要用其他的数据结构存储了 
bool vis[MAXN][MAXN];
int cnt,xf[5]={0,0,0,-1,1},yf[5]={0,1,-1,0,0};//移动的四个方向 
    int l,h,sx,sy;

void DFS(int x,int y)//搜索能走多少个 
{
    if(x>=1&&y>=1&&a[x][y]!='#'&&!vis[x][y]&&x<=h&&y<=l)//满足根节点的条件 边界有四条 不能少写 
    {                                                  //对于某些情况可初始化成墙
        ++cnt;//记录走过多少个了 
        vis[x][y]=true;//以当前节点为根节点  
        for(int i=1;i<=4;++i)
        {
            DFS(x+xf[i],y+yf[i]);//将子问题看成与原问题相同的结构 
         } 
    }
    return ;//递归必须有返回条件 
}

int main()
{

    while(~scanf("%d%d",&l,&h)&&(h||l))//以后要注意了 即使题里面的输入没有说0怎么办 
    {                                 //并且测试数据中有0 应该 引起注意 
        getchar();  
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=h;++i)
        {
            for(int j=1;j<=l;++j)
            {
                scanf("%c",&a[i][j]);

                if(a[i][j]=='@')//找出初始坐标 
                {
                    sx=i;
                    sy=j;
                }
            }
            getchar();//容易忽略 造成输出的格式都不对 
        }

        cnt=0; 
        DFS(sx,sy);
        printf("%d\n",cnt); 
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值