POJ 3278 Catch That Cow【BFS】

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 79281 Accepted: 25001

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


G++过不了,换成c++就行了;

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
 
using namespace std;

struct Node{
	int u,n;
	Node(int a=0,int b=0): u(a),n(b){} 
}; 
const int MAXN=1e5+100;
bool vis[MAXN+11];

int BFS(int S,int E) { 
    queue<Node> Q;
	Node s(S,0); Q.push(s); vis[S]=true;
	while(!Q.empty()) {
		Node F=Q.front(); Q.pop();
		if(F.u==E) return F.n;
		Node a(F.u*2,F.n+1),b(F.u-1,F.n+1),c(F.u+1,F.n+1);
		if(a.u>=0&&a.u<MAXN&&!vis[a.u]) {
			Q.push(a); vis[a.u]=true;
		}
	    if(b.u>=0&&b.u<MAXN&&!vis[b.u]) {
	    	Q.push(b); vis[b.u]=true; 
		}
		if(c.u>=0&&c.u<MAXN&&!vis[c.u]) {
		    Q.push(c); vis[c.u]=true;	
		}
	}	
}
int main()
{
	int N,K;
	while(~scanf("%d%d",&N,&K)) { 
	    if(N>=K) {
	    	printf("%d\n",N-K); continue;
		}
	    memset(vis,false,sizeof(vis));
		printf("%d\n",BFS(N,K));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值