1025 PAT Ranking (25分)

13 篇文章 0 订阅

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题⽬⼤意:

有n个考场,每个考场有若⼲数量的学⽣,给出每个考场中考⽣的编号和分数,要求算排名,输出所有考⽣的编号、排名、考场号、考场内排名

分析:

先按照考场内排名 然后对是否同分并列的情况进行特殊处理,将排名赋值给local_rank,注意再计算场内排名是总是由上一场的末尾作为下一场的开始,然后总排名,最后输出。注意相同的分数情况下按照学号的从⼩到⼤排列,但是他们的排名应该是⼀样的数字

//1025 PAT Ranking (25分)
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct stu
{
	string id;
	int local_num;
	int score,local_rank,finak_rank;
};
vector<stu> s;
bool cmp(stu s1,stu s2)
{
	if(s1.score!=s2.score)
		return s1.score>s2.score;
	else
		return s1.id.compare(s2.id)<0;
}
int main()
{
	int n,num,grade;
	cin>>n;
	for(int i=1; i<=n; i++)
	{
		cin>>num;
		int start=s.size();
		s.resize(num+s.size());
		for(int j=start; j<s.size(); j++)
		{
			string str;
			cin>>str>>grade;
			s[j].id=str;
			s[j].score=grade;
			s[j].local_num=i;
		}
		
		sort(s.begin()+start,s.end(),cmp);
			
		s[start].local_rank=1;
		for(int j=start+1; j<s.size(); j++)
		{
			s[j].local_rank=j+1-start;
			if(s[j].score==s[j-1].score)
				s[j].local_rank=s[j-1].local_rank;
		}
		
	}
	sort(s.begin(),s.end(),cmp);
	s[0].finak_rank=1;
	for(int j=1; j<s.size(); j++)
	{
		s[j].finak_rank=j+1;
		if(s[j].score==s[j-1].score)
			s[j].finak_rank=s[j-1].finak_rank;
	}
	cout<<s.size()<<endl;
	for(int i=0; i<s.size(); i++)
	{
		cout<<s[i].id<<" "<<s[i].finak_rank<<" "<<s[i].local_num<<" "<<s[i].local_rank<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值