1055 The World's Richest (25分)

13 篇文章 0 订阅

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth(integer in [−106 ,106​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题⽬⼤意:

给出n个⼈的姓名、年龄和拥有的钱,然后进⾏k次查询,每次查询输出在年龄区间内的财富值的从⼤到⼩的前m个⼈的信息。如果财富值相同就就先输出年龄⼩的,如果年龄相同就把名字按照字典序排序输出

分析:

不能先排序然后根据每⼀个条件再新建⼀个数组、对新数组排序的⽅法,这样测试点2会超时因为n和m的悬殊太⼤了,n有10的5次⽅,m却只有100个,先建立一个vector data存放数据,然后按财富,年龄,姓名的优先级排序,再建立一个vector res保存需要查询年龄段的rec信息,遍历data将符合年龄条件的加入即可,注意每个case后res要初始化

//1055 The World's Richest (25分) 
#include <bits/stdc++.h>
using namespace std; 
struct rec
{
	string name;
	int age;
	int worth;	
};
bool cmp(rec r1,rec r2)
{
	if(r1.worth!=r2.worth)
		return r1.worth>r2.worth;
	else if(r1.age!=r2.age)
		return r1.age<r2.age;
	else if(r1.name!=r2.name)
		return r1.name<r2.name;
}
int main() 
{
	int n,k;
	cin>>n>>k;
	vector<rec> data(n);
	for(int i=0;i<n;i++)
	{
		cin>>data[i].name;
		scanf("%d%d",&data[i].age,&data[i].worth);
	}
	sort(data.begin(),data.end(),cmp);
	for(int i=0;i<k;i++)
	{
		int num,l,h;
		scanf("%d%d%d",&num,&l,&h);
		vector<rec> res;
		for(int j=0;j<data.size();j++)
		{
			if(data[j].age>=l&&data[j].age<=h)
			{
				res.push_back(data[j]);
				num--;
				if(num==0)
					break;
			}				
		}
		printf("Case #%d:\n",i+1);
		if(res.size()==0)
		{
			printf("None\n");
			continue;
		}
		for(int l=0;l<res.size();l++)
		{
			printf("%s %d %d\n",res[l].name.c_str(),res[l].age,res[l].worth);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值