1059 Prime Factors (25分)

3 篇文章 0 订阅
1 篇文章 0 订阅

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​^k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​k​1​​p​2​​k​2​​…*p​m​​^k​m​​, where p​i​​’s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ – hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题意

给出⼀个整数,按照从⼩到⼤的顺序输出其分解为质因数的乘法算式

分析

先用埃氏筛选法建⽴个10000以内的素数表,然后从2开始⼀直判断是否为它的素数,如果是就将x=x/i继续判断i是否为x的素数,判断完成后输出这个素数因⼦和个数

//1059 Prime Factors (25分)
#include <iostream>
#include <cmath>
using namespace std;
struct factor
{
	int f,cnt;
} fac[100];
const int maxn=10000;
int prime[maxn],pNum=0;
bool p[maxn]= {false};
int num=0;
void find_Prime()
{
	for(int i=2; i<maxn; i++)
	{
		if(p[i]==false)
		{
			prime[pNum++]=i;
			for(int j=i*i; j<maxn; j+=i)
				p[j]=true;
		}
	}
}
void prime_factor(long int x)
{

	for(int i=0; i<sqrt(x); i++)
	{
		if(x%prime[i]==0)
		{
			fac[num].f=prime[i];
			fac[num].cnt=0;
			while(x%prime[i]==0)
			{
				fac[num].cnt++;
				x/=prime[i];
			}
			num++;
		}
	}
	if(x!=1)
	{
		fac[num].f=x;
		fac[num++].cnt=1;
	}
}
int main()
{
	long int n;
	cin>>n;
	find_Prime();
	prime_factor(n);
	cout<<n<<"=";
	if(n==1)
		cout<<1;
	for(int i=0; i<num; i++)
	{
		if(i>0)
			cout<<"*";
		cout<<fac[i].f;
		if(fac[i].cnt>1)
			cout<<"^"<<fac[i].cnt;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值