PAT甲级 - 1030 Travel Plan (30 分)

35 篇文章 0 订阅
29 篇文章 0 订阅

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40
wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 迪杰斯特拉算法首先得到最短路径值和前驱节点(最短路径),相当于先算出第一标尺。

然后使用DFS计算第二标尺。

BUG整理

  1. 对于dis和cost初始化为INF,不是0!没有通路,则初始化为无限大
  2. struct的定义 struct{}; 分号一定要有
  3. 定义一个变量的时候,如果不主动赋值,一定要初始化
  4. Dijstra,输入是起点;DFS输入是终点(因为是pre[]存储,从后向前DFS)
  5. 多层嵌套循环时,不要都用i,造成干扰;找最小的数,不仅要小,而且要没访问过
  6. 无向图要赋值两次,有向图只需要复制一次
  7. if分支的时候,if...if是错的!!!会顺序执行。使用if..else或者if...else if,
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

const int maxn = 510;
const int INF = 1E9;

struct node {
	int dis, cost;
	node(int _dis = INF, int _cost = INF) : dis(_dis), cost(_cost) {}//dis想要最小值,cost想要最小值,默认初始化为无限大!!!!不要为0!!
};
node G[maxn][maxn];
int vis[maxn] = { false };
int dis[maxn];
vector<int> pre[maxn];
vector<int> path;
vector<int> temp_path;
int N, M, S, D;
int minCost = INF;

int computeCost() {
	int now, pre, cost = 0;
	pre = temp_path[0];
	for (int i = 1; i < temp_path.size(); i++)
	{
		now = temp_path[i];
		cost += G[pre][now].cost;
		pre = now;
	}
	return cost;
}

void DFS(int front) {
	if (front == S) {//到达叶节点
		temp_path.push_back(front);
		int cost = computeCost();
		if (cost < minCost)
		{
			minCost = cost;
			path = temp_path;
		}
		temp_path.pop_back();
                return;
	}
	temp_path.push_back(front);
	for (int i = 0; i < pre[front].size(); i++) {
		DFS(pre[front][i]);
	}
	temp_path.pop_back();
}



void Dijstra(int s) {
	fill(dis, dis + maxn, INF);
	dis[s] = 0;
	for (int i = 0; i < N; i++) {
		int u = -1, MIN = INF;
		for (int j = 0; j < N; j++) { //i不要重用
			if (vis[j] == false && dis[j] < MIN) {
				u = j;
				MIN = dis[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;//使用u为跳板来更新v的距离
		for (int v = 0; v < N; v++) {
			if (vis[v] == false && G[u][v].dis != INF) {
				if (dis[u] + G[u][v].dis < dis[v]) {
					dis[v] = dis[u] + G[u][v].dis;
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if (dis[u] + G[u][v].dis == dis[v]) { //else if!!!!!
					pre[v].push_back(u);
				}
			}
		}
	}
}


int main() {
	cin >> N >> M >> S >> D;
	//node Q;
	//fill(G, G + maxn * maxn, Q);
	for (int i = 0; i < M; i++)
	{
		int m, n;
		cin >> m >> n;
		cin >> G[m][n].dis >> G[m][n].cost;
		G[n][m].dis = G[m][n].dis;
		G[n][m].cost = G[m][n].cost;
	}

	Dijstra(S);
	DFS(D);
	for (int i = path.size() - 1; i >= 0; i--) {
		cout << path[i] << " ";
	}
	cout << dis[D] << " " << minCost;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值