PAT甲级 1007 Maximum Subsequence Sum (25 分)

40 篇文章 0 订阅
29 篇文章 0 订阅

 

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

动态规划第一次试水,要注意数组和边界条件,但是自己写的发现有3个测试点一直过不去。

 

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10010;
const int INF = -1000000000;
int N;
int _left = 0, _right = 0;
int max_dp;
int num[maxn];
int dp[maxn];

int main() {
	/*
	10
	-10 5 2 3 5 -5 -23 3 7 -21
	*/
	cin >> N;
	fill(num, num + maxn, INF);
	fill(dp, dp + maxn, INF);
	for (int i = 0; i < N; i++) {
		cin >> num[i];
	}
	dp[0] = num[0];
	max_dp = 0;
	for (int i = 1; i < N; i++) {
		int flag = 0; //flag == 0 表示累积最大值
		if (dp[i - 1] > 0) //累积
		{
			dp[i] = dp[i - 1] + num[i];
			flag = 0;
		}
		else
		{
			dp[i] = num[i];
			flag = 1;
		}
		if (dp[i] > dp[max_dp]) {
			max_dp = i;
			if (flag)
			{
				_left = num[i];
			}

		}
	}
	if(dp[max_dp] >= 0)
		cout << dp[max_dp] << " " << _left << " " << num[max_dp];
	else
		cout << 0 << " " << num[0] << " " << num[N-1];

	return 0;
}

 但是更改记录数组下标的方式,可以通过测试。百思不得其解。

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10010;
const int INF = -1000000000;
int N;
int _left = 0, _right = 0;
int max_dp;
int num[maxn];
int dp[maxn];
int s[maxn] = {0};

int main() {
	/*
	10
	-10 5 2 3 5 -5 -23 3 7 -21
	*/
	cin >> N;
	fill(num, num + maxn, INF);
	fill(dp, dp + maxn, INF);
	for (int i = 0; i < N; i++) {
		cin >> num[i];
	}
	dp[0] = num[0];
	max_dp = 0;
	s[0] = num[0]; //s存储的是左端点的值
	for (int i = 1; i < N; i++) {
		if (dp[i - 1] > 0) //累积
		{
			dp[i] = dp[i - 1] + num[i];
			s[i] = s[i - 1];
		}
		else
		{
			dp[i] = num[i];
			s[i] = num[i];
		}

	}
	for (int i = 1; i < N; i++) {
		if (dp[i] > dp[max_dp]) {
			max_dp = i;
		}
	}
	if(dp[max_dp] >= 0)
		cout << dp[max_dp] << " " <<s[max_dp]<< " " << num[max_dp];
	else
		cout << 0 << " " << num[0] << " " << num[N-1];

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值