PAT - 1064 Complete Binary Search Tree (30 分) 完全二叉树和二叉搜索树

40 篇文章 0 订阅
35 篇文章 0 订阅

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

这道题自己百思不得其解,甚至想用数学规律的方法去解。

答案的思路让人一目了然: BST,中序遍历一定是递增数列;CBT,可以直接用数组存储。这样的话,直接在中序遍历的过程对树进行填充即可!

//对于BST,中序遍历序列一定是递增的; 那么首先sort,就可以得到中序遍历序列
//对于完全二叉树来说,可以用数组存储
//因此,可以对存储完全二叉树的数组进行中序遍历,在中序遍历的过程中complete the tree
// AMAZING!!!
//题,总是有方法的,联想自己学过的知识点
#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

const int maxn = 1050;
int tree[maxn]; // 从1到n存储cbt
vector<int> origin;

int n;
int index = 0;

void InOrder(int root) {
	if (root > n)
		return;
	InOrder(2 * root);
	tree[root] = origin[index++];
	InOrder(2 * root + 1);
}

int num = 0; //已输出的元素个数

void LevelOrder(int root) {
	queue<int> q;
	q.push(root); // push the index
	while (!q.empty()) {
		int root = q.front();
		printf("%d", tree[root]);
		num++;
		if (num != n) printf(" ");
		q.pop();
		if (2 * root <= n)
			q.push(2 * root);
		if (2 * root + 1 <= n)
			q.push(2 * root + 1);
	}
}

int main() {
	int tmp;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d", &tmp);
		origin.push_back(tmp);
	}
	sort(origin.begin(), origin.end());
	InOrder(1);
	LevelOrder(1);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值