HDU 1217 Arbitrage 货币交换(floyd)

点击打开链接

 

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3306    Accepted Submission(s): 1498


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 


 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 


 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 


 

Sample Input
  
  
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 


 

Sample Output
  
  
Case 1: Yes Case 2: No
 


 

Source
 


 

Recommend
Eddy

 

 

题意是说给你n种货币和m种兑换方式,让你找有没有一种货币(初始是1单位)经过兑换后能够大于1单位。

最短路,用floyd算法求出每种货币经过转换后能否超过1单位,如果有则输出Yes,否则输出No。

#include<stdio.h>
#include<string.h>
using namespace std;
double g[37][37];
char z[30];
int n,m;
struct node
{
    char s[30];
}country[37];
int main()
{
    int cas=1;
    while(scanf("%d",&n),n)
    {
        int j1,j2;
        double num;
        memset(g,0,sizeof(g));
        for(int i=1;i<=n;i++)
            scanf("%s",country[i].s);
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%s",z);
            for(j1=1;j1<=n;j1++)
                if(strcmp(country[j1].s,z)==0)
                    break;
            scanf("%lf",&num);
            scanf("%s",z);
            for(j2=1;j2<=n;j2++)
                if(strcmp(country[j2].s,z)==0)
                    break;
            g[j1][j2]=num;
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                for(int k=1;k<=n;k++)
                {
                  if(g[j][k]<g[j][i]*g[i][k])
                        g[j][k]=g[j][i]*g[i][k];
                }
        //printf("%lf\n",g[1][1]);
        int flag=0;
        for(int i=1;i<=n;i++)//查找是否存在一种货币可以获益
        {
            if(g[i][i]>1)
            {
                flag=1;
                break;
            }
        }
        if(flag)
            printf("Case %d: Yes\n",cas++);
        else
            printf("Case %d: No\n",cas++);

    }
    return 0;
}


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值