PAT甲级 1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, and are stored as showed in Figure 1.loading being

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of in Figure 1).i

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where is the position of the node, is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and is the position of the next node.Address Data Next

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output instead.-1

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1
#include <iostream>
#include <cstdio>

using namespace std;
const int M = 100000;
struct Node {
    char data;
    int next;
    bool flag = false;
} node[M];


int main() {
    int first, second, N, address, next;
    char data;
    cin >> first >> second >> N;
    for (int i = 0; i < N; ++i) {
        cin >> address >> data >> next;
        node[address].data = data;
        node[address].next = next;
    }
    for (int i = first; i != -1; i = node[i].next)
        node[i].flag = true;
    for (int i = second; i != -1; i = node[i].next) {
        if (node[i].flag) {
            printf("%05d", i);
            return 0;
        }
    }
    printf("-1");
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值