PAT甲级 1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include <iostream>

using namespace std;

int main() {
    int n, k = 0;
    cin >> n;
    string s;
    double sum = 0;
    for (int i = 0; i < n; ++i) {
        cin >> s;
        bool flag = true;
        bool flag1 = true;
        int g = 0;
        if (s[0] == '-')
            g = 1;
        for (int j = g; j < s.size(); ++j) {
            if (s[j] == '.') {
                flag1 = false;
            }
            if (isalpha(s[j])) {
                if (s[j] != '.' or !flag1)
                    flag = false;
                break;
            }
            if (s[j] == '.' and s.size() - j - 1 > 2) {
                flag = false;
                break;
            }
        }
        if (flag) {
            if (stod(s) <= 1000 and stod(s) >= -1000) {
                sum += (s != "" ? stod(s) : 0);
                k++;
            } else
                flag = false;
        }
        if (!flag)
            cout << "ERROR: " << s << " is not a legal number" << endl;
    }
    if (k > 1)
        printf("The average of %d numbers is %.2f", k, sum / k);
    else if (!k)
        printf("The average of 0 numbers is Undefined");
    else
        printf("The average of 1 number is %.2f", sum);
    return 0;
}
#include <iostream>
#include <cstring>

using namespace std;

int main() {
    int n, k = 0;
    cin >> n;
    char a[50], b[50];
    double sum = 0, temp;
    for (int i = 0; i < n; ++i) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2f", temp);
        bool flag = false;
        for (int j = 0; j < strlen(a); ++j) {
            if (a[j] != b[j]) {
                flag = true;
                break;
            }
        }
        if (flag or temp > 1000 or temp < -1000)
            printf("ERROR: %s is not a legal number\n", a);
        else {
            sum += temp;
            k++;
        }
    }
    if (k > 1)
        printf("The average of %d numbers is %.2f", k, sum / k);
    else if (!k)
        printf("The average of 0 numbers is Undefined");
    else
        printf("The average of 1 number is %.2f", sum);
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的影城管理系统,源码+数据库+论文答辩+毕业论文+视频演示 随着现在网络的快速发展,网上管理系统也逐渐快速发展起来,网上管理模式很快融入到了许多生活之中,随之就产生了“小徐影城管理系统”,这样就让小徐影城管理系统更加方便简单。 对于本小徐影城管理系统的设计来说,系统开发主要是采用java语言技术,在整个系统的设计中应用MySQL数据库来完成数据存储,具体根据小徐影城管理系统的现状来进行开发的,具体根据现实的需求来实现小徐影城管理系统网络化的管理,各类信息有序地进行存储,进入小徐影城管理系统页面之后,方可开始操作主控界面,主要功能包括管理员:首页、个人中心、用户管理、电影类型管理、放映厅管理、电影信息管理、购票统计管理、系统管理、订单管理,用户前台;首页、电影信息、电影资讯、个人中心、后台管理、在线客服等功能。 本论文主要讲述了小徐影城管理系统开发背景,该系统它主要是对需求析和功能需求做了介绍,并且对系统做了详细的测试和总结。具体从业务流程、数据库设计和系统结构等多方面的问题。望能利用先进的计算机技术和网络技术来改变目前的小徐影城管理系统状况,提高管理效率。 关键词:小徐影城管理系统;Spring Boot框架,MySQL数据库
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XdpCs

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值