UVA10298 Power Strings

Given two strings a and b we define a∗b to be their concatenation. For example, if a = ‘abc’ and b = ‘def’ then a∗b = ‘abcdef’. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a0 = ‘’ (the empty string) and a(n+1) = a∗(an).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output For each s you should print the largest n such that s = an for some string a.
Sample Input
abcd

aaaa

ababab

.

Sample Output
1

4

3

翻译:

POJ 2406:Power Strings
    题意:给一个字符串S长度不超过10^6,求最大的n使得S由n个相同的字符串a连接而成,如:"ababab"则由n=3个"ab"连接而成,"aaaa"由n=4个"a"连接而成,"abcd"则由n=1个"abcd"连接而成。

传统朴素算法时间复杂度:O(m*n)

KMP算法时间复杂度:O(m+n)

code:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>

using namespace std;
const int N=1000005;
char p[N];
int nextl[N];
void getnext()
{
    int j=0;
    int k=-1;
    nextl[0]=-1;
    while(j<strlen(p))
    {
        if(k==-1||p[j]==p[k])
        {
            nextl[++j]=++k;
        }
        else
        k=nextl[k];
    }
    return ;
}


int main()
{
	freopen("51.in","r",stdin);
	freopen("51.out","w",stdout);
    memset(nextl,0,sizeof(nextl));
    int n;
    while(1)
    {
        memset(nextl,0,sizeof(nextl));
        scanf("%s",p);
        n=strlen(p);
        if(p[0]=='.')
        {
            break;
        }
        getnext();
        if(n%((n-1)-nextl[n-1])==0)
        printf("%d\n",n/((n)-nextl[n]));
        else
        printf("1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值