Division
Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2<=N<=79. That is,abcde / fghij = N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.
Input
Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.
Output
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).
Your output should be in the following general form:
xxxxx / xxxxx = N
xxxxx / xxxxx = N
.
.
In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.
Sample Input
61
62
0
Sample Output
There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 = 62
简单的枚举,只枚举分母即可。
附代码如下:
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
struct FS{
int fz,fm;
bool operator < (const FS& x) const {return fm<x.fm;}
};
int n;
vector<FS> ans;
bool check(int fz,int fm){
bool flag[10];
memset(flag,false,sizeof(flag));
if(fz/10000>9)return false;
if(fz/1000<10)flag[0]=true;
if(fm/1000<10)flag[0]=true;
while(fz>0){
flag[fz%10]=true;
fz/=10;
}
while(fm>0){
flag[fm%10]=true;
fm/=10;
}
for(int i=0;i<10;i++)
if(!flag[i])return false;
return true;
}
int main(){
bool st=true;
while(scanf("%d",&n)==1&&n){
if(!st)printf("\n");st=false;
ans.clear();
for(int fm=1234;fm<=98765;fm++){
int fz=fm*n;
if(check(fz,fm))ans.push_back((FS){fz,fm});
}
sort(ans.begin(),ans.end());
for(int i=0;i<ans.size();i++){
printf("%05d / %05d = %d\n",ans[i].fz,ans[i].fm,n);
}
if(!ans.size())printf("There are no solutions for %d.\n",n);
}
return 0;
}