ACM 1001. 99 division

10 篇文章 0 订阅
1001. 99 division
 
 
Time Limit: 1sec    Memory Limit:256MB
Description

Given a big integer n, please determine whether it can be divided by 99 or not.

Input

Input consists of multiple test cases. The first line of input contains a positive integer T, the number of test cases.
Each test case consists of a single line which only contains a big integer n(0<=n<10^10000).

Output

 For each test case, output on a single line. If n can be divided by 99,output "Yes". If n can not be divided by 99,output "No".

Sample Input
 Copy sample input to clipboard
3
0
99
121
Sample Output
Yes
Yes
No

Problem Source: 腾讯俱乐部ACM训练赛入门组

程序:
// Problem#: 6511
// Submission#: 1697598
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<string>
using namespace std;
int main()
{
    string input;
    char tempc;
    int count=0;
    while(cin>>input){
        if(input=="XXX")
            return 0;
        else{
            for(int i=0; input[i]!='\0';i++)
            {
                if(input[i]>='a'&&input[i]<='z'){
                    cout<<input[i];
                    tempc=input[i];
                }
                else
                {
                    if(input[i]>='0'&&input[i]<='9')
                        count=count*10+input[i]-'0';
                     if(!(input[i+1]>='0'&&input[i+1]<='9'))
                     {
                         for(int j=0;j<count-1;j++)
                             cout<<tempc;
                         count=0;
                     }
                }
            }
        }
        cout<<endl;
    }
    return 0;
}                                 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值