Division

Division 
Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2<=N<=79. That is,


abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 
Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output 
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).
Your output should be in the following general form:

xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.



In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input 
61
62
0

Sample Output
There are no solutions for 61.


79546 / 01283 = 62
94736 / 01528 = 62



如果单纯的应用暴力枚举是很麻烦的,因为需要枚举两个数,再判断它们相除之后是否等于n。所以我们可以只枚举一个数,计算出另一个数,在判断一下这两个数是否有相同(不同是组成两个数的的数字要包含0~9所有的数字)即可。这样是不是就减少了大量的枚举次数呢!注意这句话:all pairs of 5-digit numbers that between them use the digits 0 through 9 once each,这句话是说这两个数字必须包含0~9这十个数字,所以如果我们枚举较小的数,是从四位数1234开始枚举的。考虑到这个特点,我们比较两个数是否相等的时候,也无需一个一个比较,只需把组成这两个数的数字从小到大排列好,看是否是0~9即可。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;

int cmp(const void* a,const void* b)
{
	return *(char*)a-*(char*)b;
}
int main()
{
	int n,Case=0;
	while(scanf("%d",&n)==1&&n)
	{
		if(Case++) printf("\n"); 
		bool flag=true;
		for(int fghij=1234;;fghij++)
		{
			bool ok=true;
			int abcde=fghij*n;
			char buf[100];
			sprintf(buf,"%05d%05d",abcde,fghij);
			if(strlen(buf)>10) break;
			qsort(buf,10,sizeof(buf[0]),cmp);
			for(int i=0;i<10;i++)
				if(buf[i]!='0'+i) ok=false;
			if(ok)
			{
				printf("%05d / %05d = %d\n",abcde,fghij,n);
				flag=false;
			}
		}
		if(flag) printf("There are no solutions for %d.\n",n);
	}
	return 0;
}

Sprintf和sscanf相对应,是把整数按照指定的形式打印到字符串中:sprintf(s,“%d”,n)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值