简单枚举 Division UVA 725

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0
through 9 once each, such that the first number divided by the second is equal to an integer N, where
2 ≤ N ≤ 79. That is,
abcde
fghij = N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be
zero.

Input
Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and,
of course, denominator).
Your output should be in the following general form:
xxxxx / xxxxx = N
xxxxx / xxxxx = N
.
.
In case there are no pairs of numerals satisfying the condition, you must write ‘There are no
solutions for N.’. Separate the output for two different values of N by a blank line.

Sample Input
61
62
0
Sample Output
There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 = 62

题解:
就暴力算,加上一点范围的缩小
还有从分子推分母再去check来优化

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

int m[15];

int check( int x, int y);

int main(int argc, const char * argv[])
{
	int num;
	
	while(cin >> num && num)
	{
		int flag = 0;
		for(int i = 1234; i <= 100000 / num; i++)
			if(check(i, i * num)){
				printf("%05d / %05d = %d\n", i*num, i, num);
				flag = 1;
			}
		
		if(!flag)
			printf("There are no solutions for %d.\n", num);
		else
			printf("\n");
	}

	return 0;
}

int check(int x, int y)
{
	memset(m, 0, sizeof(m));
	for(int i = 0; i < 5; i++)
	{
		m[x % 10]++;
		m[y % 10]++;
		if(m[x % 10] > 1 || m[y % 10] > 1)
			return 0;
		x/=10;
		y/=10;
	}
	return 1;
}

700

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值