HDU1003 Max Sum 最大连续和

10 篇文章 0 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 322027 Accepted Submission(s): 76562

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

问题连接

问题描述

求最大连续子段和

问题分析

方法一:减去最小负数前i项和
方法二:舍弃负数前缀

代码如下

方法一:

#include<iostream>
#include<cstdio>
using namespace std;
const int N=100005;
int main()
{
	int t,i,j,n,a[N];
	scanf("%d",&t);
	for(j=1;j<=t;j++)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%d",a+i);
		
		int start,end,start_point,best,pre_min;
		a[0]=0;
		pre_min=0;//最小值 
		best=a[1];
		start=end=start_point=1;
		for(i=1;i<=n;i++) a[i]+=a[i-1];//直接加,得到前i项和a[i]。dp[i]=dp[i-1]+a[i] 
		for(i=1;i<=n;i++)
		{
			if(best<a[i]-pre_min)//更新最大子段和 
			{
				best=a[i]-pre_min;//前i项和a[i]减去前i项的最小的小于0的子段和a[m],就得到最大的子段和
				start=start_point;
				end=i;
			}
			if(pre_min>a[i])//更新小于0的前段的最小值
			{
				pre_min=a[i];
				start_point=i+1;//取后一个点为起点,因为当前点对应的a[i]是小于0的 
			}
		}
		
		printf("Case %d:\n%d %d %d\n",j,best,start,end);
		if(j<t) printf("\n");
	}
	return 0;
}

方法二:

#include<iostream>
#include<cstdio>
using namespace std;
const int N=100005;
int main()
{
	int t,i,j,n,a[N];
	scanf("%d",&t);
	for(j=1;j<=t;j++)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%d",a+i);
		
		int start,end,start_point,best;
		a[0]=0;
		best=a[1];
		start=end=start_point=1;//初始化 
		
		for(i=1;i<=n;i++)
		{
			if(a[i-1]>=0) a[i]+=a[i-1];//前缀不小于0可以继续加 
			else start_point=i;//前缀小于0就舍弃,重置起点 
			if(best<a[i])//更新得到更大的结果值,起点,终点 
			{
				best=a[i];
				start=start_point;
				end=i;
			}
		}
		printf("Case %d:\n%d %d %d\n",j,best,start,end);
		if(j<t) printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值