Max Sum(HDU 1003)动态规划&最大连续和

HDU1003 Max Sum

题目链接

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input:

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output:

Case 1:
14 1 4

Case 2:
7 1 6

题目大意

每组第一个数n代表这组一共有多少个数字,求这n个数最大的连续和。第一个样例最大连续和是14,第1个数一直加到第4个数;第二个样例最大连续和是7,第1个数一直加到第6个数。最后一个样例结果输出完不用加上换行符!!!

解题思路

设置一个DP数组,初始DP[0]到DP[n-1]就是输入的n个数本身。DP[i]代表前i+1个数的最大连续和。因为要输出最大连续和的起点和终点位置,所以设置三个变量left(起点)、right(终点)、temp(预备起点)。对DP[i]和DP[i-1]两个状态,若DP[i-1]>0,则DP[i]+=DP[i-1],否则不变。若DP[i-1]<0,则更新预备起点为i。若DP[i]比当前最大连续和ans还大,则更新起点为预备起点、更新终点为i,更新ans为DP[i]。

AC代码

#include <bits/stdc++.h>
using namespace std;

const int N = 100005;

int DP[N];

int main(int argc, char** argv){
    int T,n,count,ans;
    scanf("%d",&T);
    count=1;
    while(T--){
        scanf("%d",&n);
        for(int i=0; i<n; ++i){
            scanf("%d", &DP[i]);
        }
        int left,right,temp;
        ans = DP[0];
        left = 0;
        right = 0;
        temp = 0;
        for(int i=1; i<n; ++i){
            DP[i] = max(DP[i], DP[i-1]+DP[i]);
            if(DP[i-1] < 0){
                temp = i;
            }
            if(DP[i] > ans){
                ans = DP[i];
                right = i;
                left = temp;
            }
        }
        printf("Case %d:\n",count++);
        printf("%d %d %d\n",ans,left+1,right+1);
        if(T){printf("\n");}
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值