【hdu 3579】Hello Kiki

点击题目链接

Hello Kiki
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing “门前大桥下游过一群鸭,快来快来 数一数,二四六七八”. And then the cashier put the counted coins back morosely and count again…
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki’s father found her note and he wanted to know how much coins Kiki was counting.

Input

The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

Sample Input

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

Sample Output

Case 1: 341
Case 2: 5996

题意理解

  Kiki数X枚硬币时,她要数N次。每次她都将硬币分成几个相同大小的组,分别记录每组硬币数Mi和剩余硬币数Ai。求共有多少(X)枚硬币。

解题思路

  参考中国剩余定理SCL、拓展中国剩余定理SCL

  需要注意的是,这边不能简单的用中国剩余定理SCL,而应该使用拓展中国剩余定理SCL。因为我们无法保证 m 1 , m 2 , . . . , m n m_1,m_2, ... ,m_n m1,m2,...,mn两两互质。
  那么我们就直接用模版接口套公式做就可以。

  但这里要注意:
  因为SCL中int extend_CRT(int a[],int m[],int n);最后返回的是(ret+M)%M。其中M为 m 1 , m 2 , . . . , m n m_1,m_2,...,m_n m1,m2,...,mn的最小公倍数,所以当 a 1 = 0 , a 2 = 0 , . . . , a n = 0 a_1=0,a_2=0,...,a_n=0 a1=0,a2=0,...,an=0 的时候。得到的是(0+M)%M=0,明显不符合要求。这时应该得到的正好是M才合理。所以在上面链接中提供的SCL的最后是return ((ret+M)%M)?((ret+M)%M):M;这里已经进行了特判:如果结果为0,需要输出几个模的最小公倍数。

  参考下面代码操作:
注:如果对两个函数接口不熟悉的可以参考中国剩余定理SCL、拓展中国剩余定理SCL这篇博客。

#include <iostream>
using namespace std;

int extend_gcd( int a, int b, int &x, int &y )//拓展欧几里得
{
    if( b==0 )
    {
        x = 1;
        y = 0;
        return a;
    }
    else
    {
        int r = extend_gcd(b,a%b,y,x);
        y -= x*(a/b);
        return r;
    }
}
int extend_CRT( int a[], int m[], int n )//拓展中国剩余定理
{
    int M = m[0];
    int ret = a[0];
    for(int i=1;i<n;++i)
    {
        int x,y;
        int gcd = extend_gcd(M,m[i],x,y);//调用外部函数:拓展欧几里得
        if( (a[i]-ret)%gcd != 0 ) return -1;//无解
        int lcm = M/gcd*m[i];
        int tm = ((a[i]-ret)/gcd)%(m[i]/gcd);
        ret = (ret+M*x*tm)%lcm;
        M = lcm;
    }
    return ((ret+M)%M)?((ret+M)%M):M;
}
int main()
{
    ios::sync_with_stdio(0);
    int T,N;
    int a[6],m[6];
    int ans,case_i=1;
    cin >> T;
    while(T--)
    {
        cin >> N;
        for(int i=0;i<N;++i) cin >> m[i];
        for(int i=0;i<N;++i) cin >> a[i];
        ans = extend_CRT(a,m,N);
        cout << "Case " << case_i++ << ": " << ans << endl;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值