HDU3575 Hello Kiki

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3338    Accepted Submission(s): 1234


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
 

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
 

Sample Input
  
  
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76
 

Sample Output
  
  
Case 1: 341 Case 2: 5996
 不互质的中国剩余定理用扩展欧几里得求就好了
这个题中有一个特殊情况就是b=0的时候这个时候直接最小公倍数就好了
#include <cstdio>
typedef long long LL;
LL x,y;
LL a[10];
LL m[10];
LL EXGCD(LL a,LL b){
    if(b==0){
        x=1; y=0; return a;
    }
    LL r=EXGCD(b,a%b);
    LL t=x;
    x=y;
    y=t-a/b*y;
    return r;
}
int main(){
    int T; int t=1;scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        for (int i=1; i<=n; i++)
            scanf("%lld",&m[i]);
        LL a1,a2,b1,b2;
        a1=a[1]; b1=m[1]; bool K=false;
        for(int i=2;i<=n;i++){
            a2=a[i]; b2=m[i];
            LL d=EXGCD(a1,a2);
            LL c=b2-b1;
            if(c%d){
                K=true; break;
            }
            x=x*(c/d);
            a2/=d;
            x=(x%a2+a2)%a2;
            b1=a1*x+b1;
            a1*=a2;
        }
        if(K)
            printf("Case %d: -1\n",t++);
        else{
           // b1=(b1%a1+a1)%a1;
            if(b1==0)  b1=a1;
            printf("Case %d: %lld\n",t++,b1);
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值