HDOJ 5904 LCIS (dp)

LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 569    Accepted Submission(s): 257


Problem Description
Alex has two sequences  a1,a2,...,an  and  b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n,m100000)  -- the length of two sequences. The second line contains  n  integers:  a1,a2,...,an   (1ai106) . The third line contains  n  integers:  b1,b2,...,bm   (1bi106) .

There are at most  1000  test cases and the sum of  n  and  m  does not exceed  2×106 .
 

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.
 

Sample Input
  
  
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1
 

Sample Output
  
  
1 5 0
 
思路:求两个数字串的最长公共上升子序列,但这里要求要是序列连续。
代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
#define max(a,b)(a>b?a:b)
const int Max=1000007;
int dp1[Max],dp2[Max];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        int maxx=0;
        int a,b;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a);
            dp1[a]=dp1[a-1]+1;//因为要求序列连续所以dp1[a]=dp1[a-1]+1
            maxx=max(maxx,a);//求出序列a的最大值
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d",&b);
            dp2[b]=dp2[b-1]+1;
            maxx=max(maxx,b);//求出数列a,b中的最大值
        }
        int ans=0;
        for(int i=0; i<=maxx; i++)//dp数组的最大不超过maxx
        {
            ans=max(ans,min(dp1[i],dp2[i]));//两个数列同一数字dp的最小值,所有数的最大值就是所求的最长公共单调连续递增子序列
        }
        printf("%d\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值