Don't Be a Subsequence

A subsequence of a string S is a string that can be obtained by deleting zero or more characters from S without changing the order of the remaining characters. For example, arc, artistic and (an empty string) are all subsequences of artistic; abc and ci are not.
You are given a string A consisting of lowercase English letters. Find the shortest string among the strings consisting of lowercase English letters that are not subsequences of A. If there are more than one such string, find the lexicographically smallest one among them.

Constraints
1≤|A|≤2×105
A consists of lowercase English letters.

输入

Input is given from Standard Input in the following format:
A

输出

Print the lexicographically smallest string among the shortest strings consisting of lowercase English letters that are not subsequences of A.

样例输入

atcoderregularcontest
 

样例输出

b

提示 

The string atcoderregularcontest contains a as a subsequence, but not b.

题意:求一个最短并且字典序最小的,非str的子序列的字符串。

 

整合一下其他博主的一些解释,

自己的理解就是,首先abc,肯定是d,

那么abcdefgh....26个字母都齐了(只出现一遍)的话,长度肯定是2,那么从后往前找就比较好了,

那么,就可以倒着想了,从前往后每全出现26个字母一次,答案字符串长度+1,

从后往前的找,每一个字母是前一个块没出现的字母。

 

传送门~

从后往前,当26个字母都出现一次的时候分成一组,把这个序列分成多组

如果刚好可以分成n组那么输出字串的长度为n+1并且第一个字符一定是‘a’。

否则的话长度为n,第一个字符为最前面一组中没有出现的字符。

在下一组找到上一个选的字符的位置,找出这一组后面没有出现的最小的字符,重复直到结束。

传送门

从后面扫一遍将字符串分成若干区间,分的条件是如果26个字符都出现了一次则为一个区间,并且用一个二维数组记录每个位置后面的  a—z在第几个位置,用一个一位数组及记录每个位置属于第几个区间,tot为区间的总个数,则这个子串的长度一定是区间的个数加1(区间个数不到一个为0),才能保证任何这个长度的子串不属于他的子序列。接下来就是贪心了,最前面的一定是一个不完全区间找到最小的没有出现的则这个字母打头一定是最小的字典序序列,然后找到这个字母出现位置的第一次,如果他的下个a-z字母跟他不在一个区间里那么下一个一定是这个字母,这里可以贪心从a开始寻找。

 

贴一个代码,忘记在哪找的了

#include <bits/stdc++.h>
#define range(i,a,b) for(int i=a;i<=b;++i)
#define LL long long
#define itrange(i,a,b) for(int i=a;i!=b;++i)
#define rerange(i,a,b) for(int i=a;i>=b;--i)
#define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
using namespace std;
int dp[int(2e5+5)],alpha[30],To[int(2e5+5)][30],len;
string str;
void Pre(){
    cin>>str;
    len=int(str.size());
    range(i,0,25)alpha[i]=len;
    rerange(i,len-1,0)
    {
        alpha[str[i]-'a']=i;
        for(int j=0;j<26;j++)
            To[i][j]=alpha[j];
        dp[i]=(int)1e9+7;
    }
    dp[len]=1;
}
void solve(){
    rerange(i,len-1,0)
    range(j,0,25)
            dp[i]=min(dp[i],dp[To[i][j]+1]+1);
    int pos=0;
    rerange(i,dp[0],0)range(j,0,25)if(dp[pos]==dp[To[pos][j]+1]+1)
        {
            putchar('a'+j);
            pos=To[pos][j]+1;
            break;
        }
}
int main() {
    Pre();
    solve();
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值