Strange fuction(二分答案)

Strange fuction(二分答案)

Description:

Now, here is a fuction:
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
2
100
200

Sample Output
-74.4291
-178.8534

题解:本题需要先求导,而且需要求导两次,求导过程把y看成常数,导完后会发现一阶导是单调递增的,x=0时一阶导是-y<0,根据数学知识可知一阶导函数值为0的点就是原函数取最小值的点,用二分法在0到100之间找到最接近一阶函数表达式结果的值即可。

AC代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        double y;
        cin>>y;
        double F1,DF1;
        double L=0,R=100,mid;
        while(R-L>1e-6)        //注意精度要比小数点后四位更精确一些;
        {
           mid=L+(R-L)/2;
           double DF1=42*pow(mid,6)+48*pow(mid,5)+21*pow(mid,2)+10*mid-y; //一阶导表达式;
           if(DF1>0)
           {
              R=mid;           
           }
           else
            L=mid;
        }
        F1=6*pow(mid,7)+8*pow(mid,6)+7*pow(mid,3)+5*mid*mid-y*mid;   //原函数的最小值;
        printf("%.4lf\n",F1);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值