1065 A+B and C (64bit) (20 分) 模拟 long double 的使用

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路分析:

看似简单但是,需要考虑溢出的情况,有正溢出和负溢出。

因为A,B,C的范围为[-2^63,2^63],而long long的取值范围为[-2^63,2^63],所以相加会存在溢出的问题

1,当A+B>=2^63时,显然A+B>C成立,但是A+B会超过long long的最大值,发生溢出,而A、B的最大值为2^63-1,所以A+B的最大值为2^64-2,所以使用long long存储后后溢出的值的区间为[-2^63,-2],【-2=(2^64-2)%2^64】

2,当A+B<-2^63时,显然A+B<C成立,但是A+B会超过long long的最大值,发生溢出,而A、B的最小值为-2^63,所以A+B的最小值为-2^64,所以使用long long存储后溢出的值的区间为[0,2^63),【0=(-2^64)】%2^64】  注意这个零,第三个测试点卡这个地方。

#include<stdio.h>
int main()
{
	int m;
	int i,j=1;
	long long a,b,c;
	scanf("%d",&m);
	for(i=0;i<m;i++)
	{
		scanf("%lld %lld %lld",&a,&b,&c);
		printf("Case #%d: ",j++);
		long long res=a+b;
		if(a<0&&b<0&&res>0)
	    printf("false\n");
	    else
	    if(a>0&&b>0&&res<0)
	    printf("true\n");
	    else
		if(res>c)
		printf("true\n");
		else
		if(res<=c)
		printf("false\n");
	}
	return 0;
}

插个题外话:

看到柳神的回答,这点,我在算法笔记上看到这是一个注意点,我当时也很纳闷,我试了下

可以过 ,还是实践出真知。

当然,在搜别人代码时搜到,一位博主说 :使用long double ,就不会产生溢出。

我是第一次见 long double 型变量,好像C那本书说过有这个搭配,
查了下

long double  据说精确到20位

long double 在Dev-C++中只能cout、cin,scanf、printf我试了不行。

 

 

 

 

  • 5
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值