并查集 例题:HDU 1829

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15115    Accepted Submission(s): 4917


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different 
genders and that they only interact  with bugs of the opposite gender. In his experiment, individual bugs and their interactions 
were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual 
bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number 
of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space.
 In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space.
 Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1,
 followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption 
about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
题意:就是两只相连的虫子(bug)一定是不同性别的,但是存在一种特殊的虫子是两性的(可以认为是雌雄同体,也可以认为是两性恋),给你T组数据,n只虫子,m个关系,问:有没有special bug?
思路:就是用并查集,如果原本两个独立的关系(集合),因为加 x-y 这条关系,可以将这两个集合连在一起,让其的pre[y]和pre[x]相同,也就是祖先相同(哈哈哈哈),这样就联系上有同一祖先的所有虫子的关系了。因为只有两性,所以,可以将其的深度对二取余判奇偶,同一祖先,还在同一深度(本是同一性别),它两还有关系,那就变态了哇!(special)
我的代码:
#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
using namespace std;
#define maxx 100005
int pre[maxx],rankk[maxx];
int flag;
int findp(int x)
{
    if(x==pre[x])
        return pre[x];
    else
    {
        int t=findp(pre[x]);
        rankk[x]=(rankk[pre[x]]+rankk[x])&1;
        pre[x]=t;
        return pre[x];
    }
}
void mix(int u,int v)
{
    int fu,fv;
    fu=findp(u);
    fv=findp(v);
    if(fu==fv)
    {
        if(rankk[u]==rankk[v])
            flag=1;
        return;
    }
    pre[fu]=fv;
    rankk[fu]=(rankk[u]+rankk[v]+1)&1;
}
int main()
{
    int n,m;
    int T;
    int t=1;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int u,v;
        flag=0;
        for(int i=1; i<=n; i++)
        {
            pre[i]=i;
            rankk[i]=0;
        }
        for(int i=0; i<m; i++)
        {
            cin>>u>>v;
            mix(u,v);
        }
        printf("Scenario #%d:\n",t++);
        if(flag==1)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
            cout<<endl;
    }
    return 0;
}



这里有一片详细的并查集介绍:http://www.cnblogs.com/cyjb/p/UnionFindSets.html

   
   


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值