HDU 3555 Bomb(数位DP)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 20202    Accepted Submission(s): 7548


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong

代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef __int64 LL;
LL dp[27][3];
int c[27];
//dp[i][j]:长度为i的数的第j种状态
//dp[i][0]:长度为i但是不包含49的方案数
//dp[i][1]:长度为i且不含49但是以9开头的数字的方案数
//dp[i][2]:长度为i且包含49的方案数
void init()
{
    memset(dp,0,sizeof(dp));
    dp[0][0] = 1;
    for(int i = 1; i <= 20; i++)
    {
        dp[i][0] = dp[i-1][0]*10-dp[i-1][1];//所有情况减去开头为4的情况
        dp[i][1] = dp[i-1][0]*1;//这个随便
        dp[i][2] = dp[i-1][2]*10+dp[i-1][1];//已经有的随便,有9的就加上4就行
    }
}

int cal(LL n)
{
    int k = 0;
    memset(c,0,sizeof(c));
    while(n)
    {
        c[++k] = n%10;
        n/=10;
    }
    c[k+1] = 0;
    return k;
}

void solve(int len, LL n)
{
    int flag = 0;                   //标记是否出现过49
    LL ans = 0;
    for(int i = len; i >= 1; i--)
    {
        ans+=c[i]*dp[i-1][2];       //为什么乘以c[i]因为可以有0~i-1个也就是i个
        if(flag)                    //如果之前出现过49那么直接乘以没有出现49的情况,因为初始时候已经乘以了有49的情况
            ans+=c[i]*dp[i-1][0];
        else if(c[i] > 4)           //这一位前面没有挨着49,但c[i]比4大,那么当这一位填4的时候,要加上dp[i-1][1]
            ans+=dp[i-1][1];
        if(c[i+1]==4 && c[i]==9)
            flag = 1;
    }
    printf("%I64d\n",ans);
}

int main()
{
    int t;
    LL n;
    init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        int len = cal(n+1);
        solve(len, n);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值