题目概述
东东在老家农村无聊,想种田。农田有 n 块,编号从 1~n。种田要灌溉
众所周知东东是一个魔法师,他可以消耗一定的 MP 在一块田上施展魔法,使得黄河之水天上来。他也可以消耗一定的 MP 在两块田的渠上建立传送门,使得这块田引用那块有水的田的水。 (1<=n<=3e2)
黄河之水天上来的消耗是 Wi,i 是农田编号 (1<=Wi<=1e5)
建立传送门的消耗是 Pij,i、j 是农田编号 (1<= Pij <=1e5, Pij = Pji, Pii =0)
东东为所有的田灌溉的最小消耗
输入输出
Input
第1行:一个数n
第2行到第n+1行:数wi
第n+2行到第2n+1行:矩阵即pij矩阵
Output
东东最小消耗的MP值
Sample Input
4
5
4
4
3
0 2 2 2
2 0 3 3
2 3 0 4
2 3 4 0
Sample Output
9
思路分析
这道题如果没有“黄河之水天上来”,只考虑任意两块田地之间传送门的消耗,就构成加权无向图,那么就可以用最小生成树解决。
在此基础上,“黄河之水天上来”,可以相当于一个超级源点0号
,且与其余n个点的连边权重为wi,这样经过图重构,就可以对n+1个点运用最小生成树解决。
先将所有的边按照权值由小到大排序(sort),每次取最小的边,用并查集判断如果该边的两个端点没有连通,就进行合并加入最后结果中。
核心
图重构,添加超级源点
代码
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,index;
const int maxn=3e2+5;
int par[maxn],a[maxn][maxn];
struct Edge{
int u,v,w;
bool operator<(const Edge& e){
return w<e.w;
}
}edge[maxn*maxn];
int find(int x)
{
if(par[x]==x) return x;
return par[x]=find(par[x]);
}
void unite(int x,int y)
{
x=find(x);
y=find(y);
if(x>y) swap(x,y);
if(x!=y) par[y]=x;
}
int main()
{
cin>>n;
for(int i=0;i<=n;i++)
par[i]=i;
for(index=0;index<n;index++)
{
cin>>edge[index].w;
edge[index].u=0;//超级源点
edge[index].v=index+1;
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
cin>>a[i][j]; //邻接矩阵
}
for(int i=1;i<=n;i++)
{
for(int j=i;j<=n;j++)
{
if(i!=j)
{
edge[index].u=i;
edge[index].v=j;
edge[index].w=a[i][j];
index++;
}
}
}
sort(edge,edge+index);
int num=0,ans=0;
for(int i=0;i<index;i++)
{
if(find(edge[i].u)!=find(edge[i].v))
{
unite(edge[i].u,edge[i].v);
num++;
ans+=edge[i].w;
}
if(num==n) break;
}
cout<<ans;
return 0;
}