HDU 1021

Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

题意就是输入一个n,看f(n)能否被3整除,能的话就输出“yes”,不能就输出“no”。
这道题比较坑人的一点是到最后连long long都无法存储下f(n)了,所以,需要用一些神奇的方法把f(n)处理一下。由于最后是要看能否被3整除,所以f(n) = f(n) % 3不影响结果,而且f(n)的值也变小了,所以这道题就可解了。而且要注意先打个表,否则会TLE。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxn = 1000000 + 5;
int s[maxn];

int main()
{
    int n, ni;
    memset (s, 0, sizeof(s));
    s[0] = 1;
    s[1] = 2;
    for (ni = 3; ni < 1000005; ni++) {//打表打的开心愉快
        s[ni] = (s[ni - 1] + s[ni - 2]) % 3;//取余3后,妈妈再也不用担心存不下了
    }
    while (scanf ("%d", &n) != EOF) {
        //int ok = true;
        if (s[n] % 3 == 0) cout << "yes" << endl;
        else cout << "no" << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值