Ultra-QuickSort(离散化+树状数组求逆序数)

8 篇文章 0 订阅
5 篇文章 0 订阅

Link:http://poj.org/problem?id=2299



Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 44681 Accepted: 16243

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]



AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
using namespace std;
struct node{
	int ord;
	int v;
}a[500001];
int n,c[500001],aa[500001];
int lowbit(int p)
{
	return p&(-p);
}
int sum(int p)
{
	int s=0;
	while(p>0)
	{
		s+=c[p];
		p-=lowbit(p);
	}
	return s;
}
void update(int p,int n,int k)
{
	while(p<=n)
	{
		c[p]+=k;
		p+=lowbit(p);
	}
}
bool cmp(node a,node b)
{
	return a.v<b.v;
}
int main()
{
	__int64 ans;
	while(scanf("%d",&n)&&n)
	{
		memset(aa,0,sizeof(aa));
		memset(c,0,sizeof(c));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i].v);
			a[i].ord=i;
		}
		sort(a+1,a+n+1,cmp);
		for(int i=1;i<=n;i++)
		{
			aa[a[i].ord]=i;
		}
		ans=0;
		for(int i=1;i<=n;i++)
		{
			update(aa[i],n,1);
			ans+=(i-sum(aa[i]));
		}
		printf("%I64d\n",ans);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值