2015北京网络赛题目: Fractal(打表+二分模拟)

181 篇文章 0 订阅
173 篇文章 4 订阅


Link:http://hihocoder.com/problemset/problem/1234


#1234 : Fractal

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述


This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:

1. Put four points A0(0,0), B0(0,1), C0(1,1), D0(1,0) on a cartesian coordinate system.

2. Link A0B0, B0C0, C0D0, D0A0 separately, forming square A0B0C0D0.

3. Assume we have already generated square AiBiCiDi, then square Ai+1Bi+1Ci+1Di+1 is generated by linking the midpoints of AiBi, BiCi, CiDi and DiAisuccessively.

4. Repeat step three 1000 times.

Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line and the original logo.

输入

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.

Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the logo.

输出

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

样例输入
3
0.375
0.001
0.478
样例输出
-1
4
20


AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<vector>
#define LL long long
#define MAXN 100010
using namespace std;
const int INF=1;
double eps=1e-8;
map<double,int>ma;
double da[1005];
LL ans;
void init()//打表初始化 
{
	ma.clear();
	ma[0]=INF;
	double x=0;
	double t=0.5;
	for(int i=1;i<=1001;i++)
	{
		x=(t)/2+x;
		da[i]=x;
		ma[x]=INF;
		t=0.5-x;
	}
}

int erfen(double x)
{
	int l=1,r=1001,mid;
	while(l<r)
	{
		mid=(l+r)/2;
		if(x>da[mid])
		{
			l=mid+1;
		}
		else
		{
			r=mid;
		}
	}
	return l;	
}

int main(){
	//freopen("D:\\in.txt","r",stdin);
    int T,cas,i;
    int cnt;
    double x;
    init();
    scanf("%d",&T);
    for(cas=1;cas<=T;cas++)
    {
    	scanf("%lf",&x);
    	if(ma[x]==INF)
    	{
    		printf("-1\n");
		}
		else
		{
			double s=0.25;
		/*	while(x>s)
			{
				cnt++;
				s=s+((0.5-s)/2);
			}*/  // 没有二分,TLE!!!
			cnt=erfen(x);
			ans=cnt*4;
			printf("%d\n",ans);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值