F - Wormholes POJ - 3259

F - Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题意:n个点,m条路,通过每条路需要时间t,其中有w条虫洞,通过虫洞可以使时间回溯。问能否回到出发点的时间之前。

题解:SPFA判断负环

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 5500;
const int inf = 0x3f3f3f3f;
int head[maxn],dis[maxn],inque[maxn],c[maxn],n,m,w,tot;

struct node
{
    int v;
    int t;
    int next;
}edg[maxn];

void addnode(int u,int v,int t)
{
    edg[tot].v = v;
    edg[tot].t = t;
    edg[tot].next = head[u];
    head[u] = tot++;
}

bool SPFA()
{
    queue<int>Q;
    Q.push(1);
    inque[1] = 1;
    c[1] = 1;
    dis[1] = 0;

    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        inque[u] = 0;
        for(int i = head[u];i != -1;i = edg[i].next)
        {
            int v = edg[i].v,t = edg[i].t;
            if(dis[v] > dis[u] + t)
            {
                dis[v] = dis[u] + t;
                if(!inque[v])
                {
                    Q.push(v);
                    inque[v] = 1;
                    c[v]++;
                    if(c[v] > n) return true;
                }
            }
        }
    }
    return false;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        tot = 0;
        memset(head,-1,sizeof(head));
        memset(dis,inf,sizeof(dis));
        memset(inque,0,sizeof(inque));
        memset(c,0,sizeof(c));

        scanf("%d %d %d",&n,&m,&w);
        for(int i = 1;i <= m;i++)
        {
            int u,v,t;
            scanf("%d %d %d",&u,&v,&t);
            addnode(u,v,t);
            addnode(v,u,t);
        }
        for(int i = 1;i <= w;i++)
        {
            int u,v,t;
            scanf("%d %d %d",&u,&v,&t);
            addnode(u,v,-t);
        }

        if(SPFA())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值