POJ 3259 Wormholes(SPFA 判负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

SPFA的裸题,随便找一个起点跑一次判断负环是否存在即可,若存在则输出“YES”,否则“NO”,代码如下:

#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef struct node
{
    int v,c;
    node(int vv = 0,int cc = 0):v(vv),c(cc){}
}node;
const int INF = 1 << 30;
const int maxn = 500 + 5;
int n;
bool vis[maxn];
int d[maxn],cnt[maxn];
vector<node> G[maxn];
bool SPFA(int s)
{
    queue<node> q;
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    for(int i = 0;i <= n; ++i) d[i] = INF;
    d[s] = 0;
    cnt[s] = 1;
    vis[s]=true;
    q.push(node(s,0));
    while(!q.empty())
    {
        node t = q.front();
        q.pop();
        int u = t.v;
        vis[u] = false;
        for(int i = 0;i < G[u].size(); ++i)
        {
            int v = G[u][i].v,c = G[u][i].c;
            if(d[v] > d[u] + c)
            {
                d[v] = d[u] + c;
                if(!vis[v])
                {
                    if(++cnt[v] > n) return false;
                    vis[v] = true;
                    q.push(v);
                }
            }
        }
    }
    return true;
}
int main()
{
    int f;
    cin >> f;
    while( f-- )
    {
        int m,w,x,y,c;
        cin >> n >> m >> w;
        for(int i = 1; i <= n; ++i) G[i].clear();
        for(int i = 0;i < m; ++i)
        {
            cin >> x >> y >> c;
            G[x].push_back(node(y,c));
            G[y].push_back(node(x,c));
        }
        for(int i = 0; i < w; ++i)
        {
            cin >> x >> y >> c;
            c = -c;
            G[x].push_back(node(y,c));
        }
        if(SPFA(1)) cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值