POJ 2253 Frogger(Dijkstra变式)

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

第一眼看去以为任意两个点求最小距离即可,wa了N此后终于发现此题应该用dijkstra的变式做,FrogDistandece是任意一条路径上两块石头间距离的最大值,题目大意是:选取所有的Freddy到Fiona的路径的Frogistance的最小值(最小最大值),每次松弛每个点的FrogDistance值,最后更新终点FrogDistance值。代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;
typedef struct node
{
    int x,y,d;
    node(int xx=0,int yy=0,int dd=20000000):x(xx),y(yy),d(dd){}
    bool operator < (const node t)const
    {
        return d>t.d;
    }
}node;
vector<node> vv;
bool r[1005][1005];
int cal(node a,node b)
{
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
void dijkstra(int n)
{

    node st=vv[0],en=vv[1];
    memset(r,false,sizeof(r));
    priority_queue<node> q;
    q.push(node(st.x,st.y,0));
    node t;
    while(!q.empty())
    {
        t=q.top(),q.pop();
        if(r[t.x][t.y])continue;
        r[t.x][t.y]=true;
        for(int i=1;i<n;++i)
        {
            int u=vv[i].x,v=vv[i].y;
            if(!r[u][v])
            {
                int d=cal(t,vv[i]);
                d=max(t.d,d);
                if(vv[i].d>d&&!r[u][v])
                {
                    vv[i].d=d;
                    q.push(vv[i]);
                }
            }
        }
    }
}
int main()
{
    int t,x,y,mi,p=1;
    while(scanf("%d",&t)&&t)
    {
        vv.clear();
        for(int i=0;i<t;++i)
        {
            scanf("%d %d",&x,&y);
            vv.push_back(node(x,y));
        }
        getchar();
        getchar();
        dijkstra(t);
        printf("Scenario #%d\n",p++);
        printf("Frog Distance = %.3f\n\n",sqrt((double)vv[1].d));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值