POJ - 2349 Arctic Network(最小生成树 prim算法)

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24020 Accepted: 7388

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

Code

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 1010
#define INF 0x3f3f3f3f

using namespace std;

double map[N][N];
double dis[N];
int vis[N];
int num;

struct node
{
    double x, y;
}s[N];

double getDist(int i,int j)
{
    return sqrt( (s[i].x - s[j].x) * (s[i].x - s[j].x) + (s[i].y - s[j].y) * (s[i].y - s[j].y) );
}

void prim(int n)
{
    int i,j,pos,k=0;
    double min;
    double ans[N];
    for(i=0; i<n; i++)
    {
        dis[i] = map[1][i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=0; i<n; i++)
    {
        min = INF * 1.0;
        for(j=0; j<n; j++)
        {
            if(!vis[j] && dis[j] < min)
            {
                min = dis[j];
                pos = j;
            }
        }
        if(min != INF * 1.0)
        {
            ///保存每条路径
            ans[k++] = min;
            vis[pos] = 1;
            for(j=0; j<n; j++)
            {
                if(!vis[j] && dis[j] > map[pos][j])
                {
                    dis[j] = map[pos][j];
                }
            }
        }
    }
    ///排序后去掉num条路径,即建立卫星通道
    sort(ans,ans+k);
    ///输出最长的路径,就是收发器的最小D值
    printf("%.2f\n",ans[k-num]);
}

int main()
{
    int t,i,j,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&num,&n);
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(i == j)
                    map[i][j] = 0;
                else
                    map[i][j] = INF;
            }
        }
        for(i=0;i<n;i++)
        {
            scanf("%lf %lf",&s[i].x,&s[i].y);
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                map[i][j] = getDist(i,j);
            }
        }
        prim(n);
    }
    return 0;
}

反思:

题目大意:国防部给北极前哨建设通信网络,有两种通信技术,一种是可以无视距离的卫星频道,另一种是距离小于D的无线电,现在要求能连通网络的最小距离D。第一行是测试数据组数t,每组数据第一行是卫星通道数和前哨数量,然后给出每个前哨的x,y坐标。最小生成树prim做法,初始化图后通过求每点的距离存图,类似POJ-2031,不过这个是二维~因为要求的是最小距离D,不用求路径的权值总和,用一个数组ans存每次的路径长度即可,最后从小到大排序,最长的num个路径使用卫星频道进行通信,不需要无线电,所以此时ans数组的最后一个就是收发器所需的最小距离D。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值