【PAT甲级A1023】Have Fun with Numbers (20分)(c++)

1023 Have Fun with Numbers (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意:

将一个大整数乘以2,如果乘出来的数与原来的数都是同样的数字,那么输出yes,否则no。

思路:

1.如果乘以2以后这个数进位了,进位数carry>0,那肯定不是,因为多了一个数;
2.用hash表记录出现过的数字,最后遍历hash表,表中元素全为0,则yes。

参考代码:

#include <cstdio>
#include <cstring>
int hash[10]={0};
using namespace std;
int main() {
    char str[20];
    scanf("%s",str);
    int carry(0),d;
    for(int i=strlen(str)-1;i>=0;i--){
        hash[str[i]-'0']++;
        d=(str[i]-'0')*2+carry;
        str[i]=d%10+'0';
        hash[str[i]-'0']--;
        carry=d/10;
    }
    if(!carry){
        bool flag= true;
        for(int i=0;i<10;i++){
            if(hash[i]!=0){
                flag=false;
                printf("No\n%s",str);
                break;
            }
        }
        if(flag){
            printf("Yes\n%s\n",str);
        }
    }else printf("No\n%d%s\n",carry,str);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值